تلفن x
02191002540
واتساپ x

WhatsApp Number

+989334008098

Message
ایمیل x
[email protected]
inter vlan routing چیست /نت یک
پرش لینک ها

INTER VLAN ROUTING چیست ؟

مقدمه :

در این مقاله میخواهیم اطلاعات بیشتری را درباره  INTER VLAN ROUTING  کسب کنیم . روش استفاده از  VLAN  را معرفی کرده و یک راهنما  برای درک مفهوم آن نمایش میدهیم .

سوییچ های سیسکو سری2960 دارای بدنه ای مقاوم  است همچنین به وسیله نرم افزار lan lite  اتصال سریع تری به اترنت برای کابل های شبکه ایجاد میکنند . این سوییچ ها اتصال از سری هاب های غیر هوشمند و برنامه ریزی نشده را به شبکه های بسیار پیشرفته و برنامه ریزی شده آسان میکنند . سوویچ های 2960 سیسکو نسبت به ویژگی هایی که داراست مانند : پورت های هوشمند خودکار .عیب یابی پیشرفته و به آسانی . و ….قیمت کمی را دارد.. امکان استفاده از برنامه های صوتی و تصویری و وایرلس با استفاده از lan lite  در سوییچ های 2960  سیسکو وجود دارد . همچنین سرویس های  poe   و qos  به صورت کلی برای استفاده کنندگان موجود است .

. ممکن است بخش هایی از  شبکه مجبور به اتصال به یک سوییچ در یک  LAN شوند  این قسمت ها توانایی اتصال به یکدیگر را بدون آن که از کابل جدیدی استفاده شود و یا تغییر در شبکه ایجاد کنند  دارند .

مفهوم  VLAN  و فهمیدن آن در انجام دادن وظایف و اعمال گوناگون در شبکه به شما کمک خواهد کرد .

موضوعاتی که میخواهیم در این مقالهه به آن بپردازیم عبارتند از :

  1. پیش نیاز

  2. اصطلاحات درباره  VLAN ROUTING

  3. VLAN ROUTING چیست ؟

  4.  روش های استفاده از  INTER VLAN ROUTING

  5. تاریخچه INTER VLAN

  6. راه اندازی یک  ROUTER  روتر

  7. لایه 3 سوییچ که از SVI  استفاده میکنند .

  8. پیکربندی شبکه برای INTER VLAN  و روش های راه اندازی یک روتر

  9. نتیجه گیری

 

پیش نیاز :

برای پیش نیاز فرد باید درک درستی را از مفاهیم اولیه شبکه داشته باشد و نحوه کار با  ROUTER  سیسکو را بداند و نصب و بارگیری را یاد بگیرد .

اصطلاحات VLAN routing:

  • VLAN  چیست ؟ 

  • VLAN  یک بخشی از شبکه LAN در  سوییچ تجهیزات شبکه است . که بدون در نظر گرفتن موقعیت آن ها در شبکه هاست هارا گروه بندی میکند .
  • شبکه محلی (LAN) چیست ؟

  • یکی ازانواع شبکه است که کاربرد بسیار گسترده ای دارد .و همچنین به بیان دیگر یک ارتباط فیزیکی بین دستگاه های یک شبکه است در یک منطقه کوچک محلی است .
  • لایه سه سوییچ یا چند لایه چیست ؟

  • انواع از سوییچ است که هر دو عملکرد لایه 2 سوییچ و لایه 3 روتر را انجام میدهد
  • SVI چیست ؟

  • مخفف Switched Virtual Interface   است . مربوط به خط اتصالی بالقوه است که در شبکه دستگاه هارا به  عنوان یک  ROTER  متحرک به  VLAN  متصل میکند .
  • Default Gateway چیست ؟

  • یک دستگاه فرستنده بسته IP  و فراهم کننده یک اکسس پوینت برای بقیه در یک شبکه است . برای نمونه : یک روتر میتواند این کار را انجام دهد .
  • Access Point اکسس پوینت چیست ؟

  • یک دستگاه در شبکه است که ارتباط بین روتر و سوییچ را فراهم میکند . یک وایرلس LAN  را ایجاد میکند و به عنوان یک لینک بین روتر و استفاده کننده های شبکه عمل میکند .
  • پورت سوییچ چیست ؟

  • مربوط به قسمت های فیزیکی ورودی در یک سوییچ است که کابل های اترنت به آن قسمت وصل میشود .
  • Router Interface چیست ؟

  • مربوط به مسیری است که روتر را قادر میسازد به شبکه متصل شود .

Inter VLAN routing چیست ؟

LANS VITUAL   (VLANS) بخش هایی از شبکه هستند که به شبکه لن متصل میشوند .

Inter VLAN routing به حرکت بسته ها در سرتاسر شبکه بین هاست ها در بخش های مختلف اشاره دارد   VLAN  را میتوان به وسیله بسته بندی هاست های مختلف شبکه را بهبود ببخشد . و به عنوان زیر ساخت شبکه برای انتقال بسته ها بین  VLAN  دیگری ما باید شبکه  VLAN  را پیکربندی کنیم.

روش های استفاده از  VLAN

  1. در این روش روتر های متعددی استفاده میشوند . هر ارتباط بین پورت های سوییچ در VLAN  متفاوت است . این خط های اتصال به عنوان ورودی هایی عنوان میشوند که در صورت گسترش شبکه نیاز به کابل کشی اضافه دارند . بنابراین افزودن کابل های شبکه هزینه بیشتری را به دنبال خواهد داشت .
  2. راه اندازی روتر : در این روش بر خلاف روش قبل .یک پورت خط اتصال فیزیکی  برای  ROUTING  بین بخش های شبکه استفاده میشود . یک شبکه نیاز به خط اتصال  VLAN  جدا گانه ندارد .

علاوه بر آن تمام خطوط از یک تا ده به وسیله یک خط اتصال ساخته شده اند . . این روش انجام پذیری ساده ای دارد . و برای شبکه های کوچک تر استفاده میشود .

لایه 3 سوییچ ها برای  SVI  استفاده میشوند .

در این روش  inter VLAN routing thatاز سوییچ های سه لایه یا چند لایه و  SVI  استفاده میکند .

SVI  ها برای  VLAN ها ساخته شده اند و در سوییچ ها موجود میباشند . که همان عملکردی را برای VLAN انجام میدهد که روتر انجام میدهد .

لایه 3 سوییچ ها  گران هستند . که عمدتا برای شبکه های بزرگ مناسب هستند .

در این مقاله . ما یاد خواهیم گرفت که چگونه  inter VLAN routing را شناسایی کنیم .

در نظر بگیرید که یک شبکه  LAN  با 4  PC  و یک سوییچ و یک روتر اتصال پیدا میکنند مانند تصویر زیر:

 

 INTER VLAN ROUTING
INTER VLAN ROUTING نت یک

اکنون ما باید دو  VLAN  را به وسیله  PC0 و  PC1 و VLAN 10 پیکربندی کنیم :

  • IP Address برای PCO  : 1 92.168.1.10
  • IP Address برای PC1 : 192.168.2.10
  • IP Addressبرای PC2 : 168.2.10
  • IP Address برای PC3 : 168.2.20
  • default gateway برای VLAN 10 :: 168.1.1
  • default gateway برای  VLAN 20 : 168.2.1

مرحله یک :

برای ما طبقه بندی کردن شبکه به دو بخش  مجبور هستیم که دو VLANS را در سوییچ بسازیم

VLAN10 و VLAN20 .

برای ساختن VLAN ها ما باید یک پیکربندی که به عنوان config terminal شناخته میشود .ایجاد کنیم . سپس ما شماره VLAN ها را مانند vlan 10 وارد میکنیم :

Switch>enable                       !moving from user exec mode to priviledge mode

Switch#config terminal              !moving from priviledge mode to global configuration mode

Switch(config)#vlan 10              !assigning vlan number

Switch(config-vlan)#name student    !assigns the vlan 10 the name student

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#name staff      !assigns vlan 20 the name staff

Switch(config-vlan)#exit

مرحله دو :

یک پورت سوییچ را به  VLAN  اختصاص میدهیم . به عنوان اکسس پورت برای  VLAN 10 پورت fa0/1 و  fa0/2

همچنین که پورت fa0/3و fa0/4 برای  VLAN 20 .  استفاده میشود .

ما باید از پورت های fa0/5 برای پورت های ترانک استفاده کنیم تا حجم ترافیک ایجاد شده بین دو  vlan  یا  router  را کاهش دهیم .

توجه :  fa  به پورت های اتصال سریع اترنت اشاره دارد که برای اتصال هاست های شبکه به سوییچ یا روتر استفاده میشود .

پیکربندی برای دسترسی پورت های fa0/1 و fa0/2 :

Switch>enable                                   !moving from user exec mode to the priviledge mode

Switch#config terminal                          !moving from priviledge mode to the global configuration mode

Switch(config)#int fa 0/1                       !entering the interface port

Switch(config-if)#switchport mode access        !making the interface fa0/1 an access port

Switch(config-if)#switchport access vlan 10     !making interface access port for vlan 10

Switch(config-if)#exit                          !exiting from the interface

Switch(config)#int fa 0/2                       !entering the interface port

Switch(config-if)#switchport mode access        !making the interface fa0/2 an access port

Switch(config-if)#switchport access vlan 10     !making interface access port for vlan 10

Switch(config-if)#exit                          !exiting from the interface

در پیکربندی بالا . پورت های  fa0/1 و fa0/2 راه اندازی شده اند . و برای دسترسی پورت ها استفاده از switchport mode acces. پیشنهاد میشود .

نکته : همان طور که در بالا مطرح شد این پیکربندی به vlan10 تعلق دارد و switchport access vlan 10 برای دسترسی به پورت آن استفاده میشود .

پیکربندی برای دسترسی به پورت  fa0/3 و fa0/4 :

Switch(config)#int fa 0/3                     !entering the interface port

Switch(config-if)#switchport mode access      !making the interface fa0/3 an access port

Switch(config-if)#switchport access vlan 20   !making interface access port for vlan 10

Switch(config-if)#exit                        !exiting from the interface

Switch(config)#int fa 0/4                     !entering the interface port

Switch(config-if)#switchport mode access      !making the interface fa0/4 an access port

Switch(config-if)#switchport access vlan 20   !making interface access port for vlan 10

Switch(config-if)#exit

در پیکربندی بالا پورت های fa0/3 و fa0/4 متصل شده اند و برای اتصال آن ها استفاده از switchport mode access پیشنهاد داده میشود .

 

با توجه به این که این الگو به  vlan 20  تعلق دارد . پس سوییچ اکسس پیشنهادی نیز برای  vlan 20  استفاده میشود .

پیکربندی یا الگوی اتصال پورت ترانک fa0/5

Switch(config)#int fa 0/5                 !entering the interface port

Switch(config-if)#switchport mode trunk   !making interface a trunk port.

Switch(config-if)#do write                !saving the running configurations to start-up file

از کد های اتصالی بالا . fa0/5 به عنوان پورت ترانک عمل میکند .. و همچنین مانند مثال های بالا از switchport mode trunk استفاده میکنیم .

مرحله 3 :

ابتدا میبایست از یک  ip  ادرس ثابت استفاده کنیم . سپس این  ip  ادرس را بر روی  pc  های شبکه ست کنیم .

INTER VLAN ROUTING
INTER VLAN ROUTING نت یک-5

مرحله 4 :

روتر را طوری راه اندازی کنیم که قادر باشد حجم داده ها را از  vlan 10  به  vlan 20  جابه جا کند . برای کامپیوتر هایی که میخواهند با یکدیگر ارتباط بگیرند . ما میبایست یک خط اتصال را به چندین خط تقسیم کنیم . به طوری که هر کدام از این خط ها بتوانند برای  vlan  نقش یک default gateways را بازی کنند این کار به شما اجازه میدهد تا بتوانید چندین شبکه را به یک خط ارتباطی متصل کنید .

Router>enable                       !moving from user exec mode to the priviledge exec mode

Router#config terminal              !moving from priviledge exec mode to the global configuration mode

Router(config)#int g0/0             !entering on our physical router interface gigabitEthernet 0/0

Router(config-if)#no shutdown       !activating the interface

Router(config-if)#int g0/0.10       !first sub interface for vlan 10 on g0/0

Router(config-subif)#encapsulation dot1q 10             !configuring the sub interface to respond to traffic from vlan 10

Router(config-subif)#ip add 192.168.1.1 255.255.255.0   !configuring the IP address of the sub interface g0/0.10

Router(config-subif)#exit           !exiting from the sub interface

Router(config)#int g0/0           !entering our physical router interface

Router(config-if)#no shutdown     !activating our physical interface

Router(config-if)#int g0/0.20     !second sub interface for vlan 20 on g0/0

Router(config-subif)#encapsulation dot1q 20             !configuring the sub interface to respond to traffic from vlan 20

Router(config-subif)#ip add 192.168.2.1 255.255.255.0   !configuring the IP address of the sub interface g0/0.20

Router(config-subif)#exit

Router(config)#do write             !saving our running configurations into the start-up configuration file

Router(config)#exit

از الگوی بالا خط ارتباطی g0/0 به دو خط  g0/0.10 برای  VLAN10 و خط g0/0.20 برای VLAN20 تقسیم شده است .

سپس این دو خط  ip  ادرس های مجزایی را کسب کرده و به عنوان یک پورت ترانک برای حمل داده ها استفاده میشوند .

 

مرحله 5 :

برای تست کردن اتصال های بین  inter VLAN ها سعی کنید کامپیوتر های مختلف را بهم پینگ کنید .

برای مثال : ما کامپیوتر شماره 2PC2  را در  vlan 20  به کامپیوتر  PC0 در vlan 10  با استفاده از الگوی زیر پینگ میکنیم .

 INTER VLAN ROUTING
INTER VLAN ROUTING نت یک-6

نتیجه گیری :

Inter VLAN routing یک مفهوم بسیار مهم برای کسانی است که میخواهند در زمینه پسیو شبکه و تجهیزات شبکه فعالیت کنند و دانستن آن از ضروریاتی حساب میشود که باید آن را درک کنند . و اینکه  استفاده از  vlan ها بهترین راه و راحت ترین راه برای تقسیم بندی و طبقه بندی  lan  های بزرگ است . و شمارا قادر میسازد که ارتباط بین هاست های شبکه های مختلف را با یکدیگر فراهم آورید .

ما در این مقاله:

  1. آموختیم : VLAN routing چیست ؟

  2. روش مختلف استفاده از VLAN routing را توضیح دادیم .

  3. روش های نصب و راه اندازی پورت ها را آموزش دادیم .

امیدواریم که از این مقاله بهره مناسب را برده باشید .

پیام بگذارید